You are not logged in.

  • Register to access all forum features  

#1

bugalug
Member
Joined: 22 September 2019
Posts: 18
Member
08 July 2021 09:18 pm

Hi,looking for advice,my old GP Extreme has spat the dummy,was making weird noises,controls except tone&volume not responding,replaced battery but no luck.Hoping for any ideas on DIY or where/who I could take it to.Any advice appreciated.

#2

Nuggetbuster
Member
Joined: 20 October 2014
Posts: 539
Member
08 July 2021 10:06 pm

Contact Detectronics Australia (AuMan on this forum):

https://www.prospectingaustralia.com.au … hp?id=2670

https://www.detectronicsaustralia.com/mods

4 users like this post: grubstake, Prooz, ProspectorPete, Ded Driver

#3

bugalug
Member
Joined: 22 September 2019
Posts: 18
Member
08 July 2021 10:30 pm

Thank you Nuggetbuster,will contact him asap,need to start process/get advice before I open control box myself yikes,much appreciated

1 user likes this post: grubstake

#4

Nuggetbuster
Member
Joined: 20 October 2014
Posts: 539
Member
08 July 2021 11:12 pm

No worries!

#5

silver
Member
Joined: 19 December 2013
Posts: 17,835
Member
09 July 2021 12:23 am

Pretty sure some detectors can do a factory reset, maybe have a look in the booklet to see if it's an option, cause that's where you'll find how to do it. big_smile


What a great day ! ,... " I'll see you in the field ".

#6

silver
Member
Joined: 19 December 2013
Posts: 17,835
Member
09 July 2021 12:41 am

This came up top on the search
1625751648_screenshot_2021-07-08-23-39-38.jpg

Link to search page

http://www.google.com/search?q=minelab+ … 5750699774


What a great day ! ,... " I'll see you in the field ".

#7

bugalug
Member
Joined: 22 September 2019
Posts: 18
Member
09 July 2021 12:59 am

Thanx Silver though my detector is old and analogue,think it is a physical thing or voltage ect. Have sent email to AU man but he is in WA so will have to wait for his reply.Can't stop trying to fix myself cos I'm an impatient psycho with tech & mechanics devil

2 users like this post: Bonacini, silver

#8

silver
Member
Joined: 19 December 2013
Posts: 17,835
Member
09 July 2021 07:53 am

Not a loose cable conection at all hey.... and don't electronic parts have a particular smell when they burn out... get your nose and give it a sniff... otherwise, migjt someone have a control box by itself for sale (or a whole unit)... then you will have some spares.
You could run a wanted add on here to see if anyone on here has one they wantbto part with.


What a great day ! ,... " I'll see you in the field ".

#9

old hand
Member
From: golden triangle
Joined: 26 July 2014
Posts: 1,640
Member
09 July 2021 09:29 am

There is a person i think he is in Dunolly he is the mechanic or something like that i will try to find out more info today regards john


golden triangle

#10

PhaseTech
Phase Technical
From: Adelaide, SA
Joined: 29 May 2014
Posts: 2,160
Phase Technical
09 July 2021 09:49 am

Google got that one wrong, there's no factory reset on the GP extreme. That started with the GPX4000 onwards.


Agent for Minelab, Nugget Finder, Nokta Makro, Quest, Detech, SteelPhase - Phase Technical Website
Digging with PhaseTech on YouTube

2 users like this post: silver, Ded Driver

#11

Leroy
Member
Joined: 26 May 2016
Posts: 281
Member
09 July 2021 10:04 am

Detectronics in Dunolly is your man but he is in WA for another 2 weeks

#12

Deepseeker
Member
Joined: 13 August 2018
Posts: 1,848
Member
09 July 2021 11:10 am

bugalug wrote:

Hi,looking for advice,my old GP Extreme has spat the dummy,was making weird noises,controls except tone&volume not responding,replaced battery but no luck.Hoping for any ideas on DIY or where/who I could take it to.Any advice appreciated.

I'm no whizz with detectors or electronics, and this may sound obvious but.... Have you tried a different coil first? I only say this because the weird noises and nothing responding except volume was exactly what my 5000 did until I changed coils and found it was the coil that was faulty.

-D.S.


Try hard not to offend. Try even harder not to be offended.

#13

Jaros
Moderator
From: S.E.Qld., QLD
Joined: 11 August 2013
Posts: 14,866
Moderator
09 July 2021 02:08 pm

Tis worth a try.


F1A4M2, Exterra 705 Gold, Ace 250, Goldrat 8" Dreammat River Sluice.

#14

bugalug
Member
Joined: 22 September 2019
Posts: 18
Member
10 July 2021 12:20 am

Thanx for all the replies and help from everyone thumbsup Have actually found fault,Deepseeker you were very close,didn't have a spare coil but found broken cable that was shorting on shaft near coil,finally multi meter has earnt its keep.Do have to replace and get spares and hopefully some mods but is a little used clean machine and intend to use my beginners luck card[again]!.Thanx again for your inputs

2 users like this post: silver, Deepseeker

#15

AuMan
Member
Joined: 16 March 2014
Posts: 217
Member
20 July 2021 07:56 pm

bugalug wrote:

Thanx for all the replies and help from everyone thumbsup Have actually found fault,Deepseeker you were very close,didn't have a spare coil but found broken cable that was shorting on shaft near coil,finally multi meter has earnt its keep.Do have to replace and get spares and hopefully some mods but is a little used clean machine and intend to use my beginners luck card[again]!.Thanx again for your inputs

Glad you got it sorted.
Thankfully I made it back before the country imploded again.. bomb

Cheers Mick

2 users like this post: Jaros, bugalug

Top