You are not logged in.

  • Register to access all forum features  

#26

Goldpick
Moderator
From: Mount Gambier
Joined: 07 November 2013
Posts: 7,011
Moderator
12 November 2017 08:59 pm

It is very confusing, aside from I've had an excellent run from my Deus since purchased - only been through one charging clip and WS4 backphone headband so far, and one other software issue that was resolved via an update. All I can say is that it is a lot tougher detector than first thought, mine doesn't get an easy life either. Also still on my original shaft, camlocks, remote mount and batteries which hold good charge.


Prospecting gear: Used - Whites GM3, GM2, GMT, ML XT17000, ML X-Terra 305, Garrett Gold Stinger, Tesoro Vaquero, Nokta RS pinpointer, Minelab Explorer SE Pro/Etrac, Ace 250
Current - XP Deus, Makro Racer 2, Fisher F75, Tesoro Tejon, Teknetics G2, Whites SPP, Garrett Infinium, Minelab Go-Find 60, XP MI-6, Minelab Profind, Whites Bullseye TRX, Deteknix X-pointer, Garrett AT Pointer

#27

trev111
Member
Joined: 06 August 2014
Posts: 62
Member
19 November 2017 10:11 am

Downloaded to 4.1, still same issues although this hunt, problems started within the first 15 minutes , and then seemed to go ok.
Still not a hugh problem, but a big pain in the neck.
Looking forward to having this fixed re XP update????????

#28

rocketaroo
Member
Joined: 11 January 2015
Posts: 5,133
Member
20 November 2017 07:18 am

4.0 is stable for me, not an issue since I reloaded it about 5 hunts ago. I suspect it's not hitting small silvers, as well as 4.1 though.


326 Silvers for the year, as at 17-11

#29

rocketaroo
Member
Joined: 11 January 2015
Posts: 5,133
Member
20 November 2017 07:19 am

trev111 wrote:

Downloaded to 4.1, still same issues although this hunt, problems started within the first 15 minutes , and then seemed to go ok.
Still not a hugh problem, but a big pain in the neck.
Looking forward to having this fixed re XP update????????

run 4.0, it's looking stable.


326 Silvers for the year, as at 17-11

#30

rocketaroo
Member
Joined: 11 January 2015
Posts: 5,133
Member
20 November 2017 07:23 am

Goldpick wrote:

It is very confusing, aside from I've had an excellent run from my Deus since purchased - only been through one charging clip and WS4 backphone headband so far, and one other software issue that was resolved via an update. All I can say is that it is a lot tougher detector than first thought, mine doesn't get an easy life either. Also still on my original shaft, camlocks, remote mount and batteries which hold good charge.

Mine, 1 broken camlock clip, one ws4band, 2 remote clips, and one of three charging connectors, no longer work. I dont treat it like a princess either, its a tough rig in most respects.


326 Silvers for the year, as at 17-11

1 user likes this post: Goldpick

#31

trev111
Member
Joined: 06 August 2014
Posts: 62
Member
02 December 2017 11:59 am

Have updated to 4.1. Seems to have fixed most of my problems. However, when turning on the PP, it sometimes takes some time to switch on, although the detector shows that it is working. On one occasion, I had to turn off the PP and then switch back on.
Still a pain in the ar............

#32

rocketaroo
Member
Joined: 11 January 2015
Posts: 5,133
Member
02 December 2017 01:00 pm

mine has been fine for 7 or so hunts, since using a fresh install of 4.0 I wont be updating again, unless its a guaranteed bug free release.


326 Silvers for the year, as at 17-11

#33

Albundy
Member
Joined: 11 November 2016
Posts: 154
Member
02 December 2017 06:49 pm

Glad I never updated. Mine doesn't miss a beat. Only issue I've had is the coil never seems to fully charge no matter how long I leave it charging.

#34

trev111
Member
Joined: 06 August 2014
Posts: 62
Member
03 December 2017 01:50 pm

4 hour hunt today. Absolutely no problems. Went like a beaut. Using the 4.1 update

#35

trev111
Member
Joined: 06 August 2014
Posts: 62
Member
06 December 2017 09:43 am

Another 3 hours yesterday ---Still no problems other than p[npointer occasionally taking a bit longer to turn off and return to the coil.
To make sure that detector coil is working, after returning from pinpointer, I slip a ringpull into my shoe and wave the coil over it. Saves time and aggravation.

#36

trev111
Member
Joined: 06 August 2014
Posts: 62
Member
09 December 2017 05:11 pm

4 hours this morning. Same old poblem came back. Turn off the PP and the coil fails . I had to turn it off and then back on to get it to right itself.
It happenend once in gthe first 5 minutes and then about 4 times. Hope XP can get it right soon


Contact Us - Privacy Policy - Terms Of Service

View Desktop Site

Top